Skip to main content

LINUX - First binary version

The first official binary version of Lucas Chess on Linux has just been released.

It has only been made possible by the great work done by Laudecir Daniel, choosing and compiling the 67 engines, as well as laying the groundwork so that the binaries can be more widely used and others such as shortcut creation, installation scripts, ......

In addition, Graham O'Neill has provided Linux-specific drivers for several digital boards.


This version has two limitations:

  • 64-bit Linux OS only.
  • Minimum GNU libc version: 2.26 (ldd --version shows it)


Installation has been made as simple as possible:

  • The installer is a .sh file, generated with the makeself tool, and can be downloaded from:
  • The file must be run from a terminal with user permissions only:
    • sh ./LucasChessR123_LINUX.sh
  • Launches a GUI with very basic options:
    • Install:
      • Installs in LucasChessR folder inside the home user folder.
      • Generates a shortcut in Applications > Games
      • Launch the application at the end when pressing Close.
    • Plays Lucas Chess without installing only to test.




Comments

  1. Unable to add new engines and open pgn files from. There are some bugs, but otherwise it works. Generally, thanks for the Linux version.

    ReplyDelete
    Replies
    1. The program creates a file = bug.log, with the errors it finds.
      It is a text file, if you want you can send it to lukasmonk at gmail or a link to a download site or copy it directly here.

      Delete
    2. However it works, but I have to run the app as root and I updated png-libraries

      Delete
  2. Hi Lucas, I've installed this official version on my laptop running Debian 11 and everything is working fine, it's an absolute delight using this awesome piece of chess software :) thanks so much for all your hard work!!

    I am however experiencing a rather strange bug, it's not a big deal but it does affect one of my favorite features of the program. I thought I'd mention it in case there is a simple solution for it. It was also present in the first Google Drive version you posted.
    The bug occurs when I use this feature: Train-> Games-> Learn a game-> Playing against.

    Immediately after a fresh install of Lucas Chess, this feature works absolutely fine, I can go in, load a PGN game and play through the game and everything works perfect but the more I use this feature the slower it gets, it's really weird. Like after I use it 5 or 6 times it starts to get really slow to load, I'll click on 'Play against' and the window that usually pops up immediately starts to take more and more time to appear, on a previous installation it even reached a point where nothing would appear at all in the window, it just appears black and my laptop would start to hang and a message asking me if I want to force quit would appear. I'm not trying to load a huge database either, it's only a small collection of Fischer's games (around 400 games).

    My current installation of Lucas Chess is only a few days old, I've used this training exercise 8 times and right now it's slow but still working, when I click 'Playing against' the pop window appears black and the program hangs for a little while, when the window finally appears properly and I try to click the + sign to add a new game from either a PGN file or database, the force quit message appears but if I wait a few seconds, I can still choose a game, everything remains laggy until the window where I have to chose the side I will play, after that there is no problem, I can play through the entire game with the tutor and everything else working fine, no lag. Maybe I should also mention that I have a pretty weak Celeron laptop with 4gb of RAM, although I don't think that's the problem since the first few times I use this feature everything works perfect.

    Anyways it's not a huge deal, I've been distro-hopping quite a bit recently so I'm always reinstalling Lucas Chess :D Everything else is working fine :)

    Thanks again!
    Sandy

    ReplyDelete
    Replies
    1. It's not a Linux problem, it's an application problem, I've just fixed it. The first time it do the reading after installing the patch it will also be quite slow, but in successive times the time will be normal.

      If you want to test the patch, just copy the file

      https://drive.google.com/file/d/16Wf-bgH25BagxAVVN35yKHKUBjwlLFHk/view?usp=sharing

      ...in bin/Code/QT replacing one with the same name.

      Delete
    2. Hey Lucas, thanks for the quick reply and patch :) Before I checked the blog here, this morning, I came up with a simple workaround, all I had to do was delete all the games (around 10) that I had played so far from the first window that appears when I click on 'Playing against'. After that, everything worked smoothly again just like on a fresh install of the program :) it doesn't really bother me to delete those games because I don't usually replay games I've played through once in that training mode.

      Of course, I've downloaded and applied your patch but I can't tell right now if it works (I'm sure it does) since I just cleared all the games from that initial window and everything was working smoothly anyway. I'll be sure to report here if there is any issue.

      Thanks again :)
      Sandy

      Delete
  3. Hello

    Thank you very much for your awesome work, installed very easily on debian buster with ratpoison window manager

    But I have a problem, the program started just fine, but when I click on Documents under Information, nothing happens

    i checked the bug.log file, but there is nothing there

    thanks!

    ReplyDelete
  4. but I think that is just a problem with my browser, because I think it's links to the website


    But now I have another problem, when I click on 'Check for updates' I receive: Encountered a network problem, cannot access the Internet

    How to solve this?

    Much appreciate

    ReplyDelete
    Replies
    1. You could try, previously:

      export PYTHONHTTPSVERIFY=0

      I have made some changes to the code, so it will not be necessary in the future.

      Delete
  5. Getting the following information when I run the installer:

    "./LucasChessR126_LINUX.sh
    Verifying archive integrity... 100% MD5 checksums are OK. All good.
    Uncompressing Lucas Chess R 1.26 100%
    No protocol specified
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, webgl, xcb.

    Aborted (core dumped)"

    I tried installing the qt stuff, but the message didn't went away. Can you instruct me which prerequisites I need exactly? Thanks.

    ReplyDelete
    Replies
    1. Prerequisites,
      64-bit Linux OS only.
      Minimum GNU libc version: 2.26 (ldd --version shows it)

      Delete
    2. I got Ubuntu 20.04 LTS 64bits, which runs a higher libc version than 2.26.
      The issue seems to be related to Qt or some plugins...I don't understand what's missing.

      Delete
  6. I got Ubuntu 20.04 LTS 64bits, which runs a higher libc version than 2.26.
    The issue seems to be related to Qt or some plugins...I don't understand what's missing.

    ReplyDelete
    Replies
    1. I just tried Ubuntu 20.04, with a freshly installed version, actually using Try Ubuntu, I downloaded the program and it ran correctly.

      Delete
    2. Unfortunately I can't reinstall it, is there a way to find out what's going wrong? Isn't Qt pointing at something?

      Delete
    3. Unfortunately I can't reinstall it, is there a way to find out what's going wrong? Isn't Qt pointing at something?

      Delete
    4. From the ignorance, perhaps: sudo apt-get install qt5-default

      Delete
    5. The error message stays the same.

      Delete
    6. The error message stays the same.

      Delete
    7. https://drive.google.com/file/d/1GyS3eYN45b1oxr1r9tJq0i37M7AkUxYH/view?usp=sharing
      This is an installation done in Ubuntu 20.04, if you want to test it.

      Delete
  7. hello version 1.26 R
    by wanting to create a polyglot book, after confirmation the program crashe and closes, with no polyglot creation in my book folder

    ReplyDelete
  8. Hi ,this soft is awesome ,but i have idea to add analysis option profile from lichess ane chess.com,how many good moves ,bad moves ,blunders etc.And when some chose analysisis they can chose profile default ,lichess or chess.com.
    This could be awesome option.

    ReplyDelete
  9. This doesn't work for me. When I try to run it I only get a short error messsage...

    $ cd ~/LucasChessR/
    $ ./LucasR.sh
    [44876] Failed to execute script Launcher

    I'm running Arch Linux, my libc version is 2.33

    ReplyDelete
    Replies
    1. I have the same problem and it is arch linux

      Delete
    2. It is not easy to determine what the problem is.
      You can run the program directly:

      $ cd ~/LucasChessR/bin
      $ ./LucasR

      Delete
    3. I have already tried this gives the same error no details. Is there a debug mod?

      Delete
    4. There is a bug.log file in the bin folder.
      Although it probably does not include information, because the problem is prior to the time the Python code is executed.
      But does it work launching it from the Lucas.py source code?

      Delete
    5. First it gave the error "There is no module called sip" I have installed python-sip4 from arch's extra repo and also sip. Now it give these errors
      "/home/erol/lucaschess/Lucas.py:15: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
      from imp import reload
      Traceback (most recent call last):
      File "/home/erol/lucaschess/Lucas.py", line 19, in
      sys.setdefaultencoding("latin-1")
      AttributeError: module 'sys' has no attribute 'setdefaultencoding'
      "

      Delete
    6. I tried to remove python-sip4 and install sip using pip but it says requirement are already satisfied so does not install anything however still getting there is no module sip

      Delete
    7. https://stackoverflow.com/questions/45252305/attributeerror-module-sys-has-no-attribute-setdefaultencoding

      Delete
    8. I commented out the setdefeaultencode and also add a line to VarGen.py "print(isLinux)" which gave false and add the line print(platform.architecture()) which printed out ('64bit', 'Elf)'. So I overwrite this os check by adding isLinux=True .Then got this error No module named '__builtin__' and learned that this module renamed in python 3 to builtins. After seeing error about cPickle module and learned that its name change to pickle I now understand you are using python 2.7 but I have already started so I have changed few more name now it cannot find module named LCEngine4. Couldn't figure it out

      Delete
    9. Also cannot use python2.7 if you wanna use sip because it only support 3.6<=

      Delete
    10. You must download the source code from the lucasChessR repository on GitHub, following the link in this article.
      You are using the old version of the program, which was coded in python 2.7 and with pyqt4 as the graphics library.
      LucasChessR uses python 3.7+ and the pyside2 graphics library.


      Delete
  10. Hello and thanks a lot for your work. I love Lucas-Chess on Windows, but on Linux its just a Beta-Version. I use Mint 22.2 with Kernel 5.4 and 5.11 and have many problems.
    I will change the colours, and if i choose a colour, LC crashes. I try to save a game, LC crashes, and more and more and more.....
    And sorry for my english, im german.

    ReplyDelete
    Replies
    1. Not much experience with Linux.
      But I think this solves it:

      cd ~/LucasChessR
      sudo ./LucasR

      Delete
  11. Hi Lucas
    I wanted to download a previous version of LucasChess, however I'm unable to download anything from Version R 1.14 and older as Bintray does no longer host your file. Could this be solved?

    I updated the program recently and noticed at least a couple older chess engines did no longer work, such as ProDeo 16 and Atlas 360. That's why I wanted to backtrack to a version when it still worked.

    ReplyDelete
    Replies
    1. From my point of view the interesting thing is to find out what has happened so that they don't work now.
      In the old versions there was a bug that if no time or depth limits were set, and no time was set for the game, it was always set to a limit of 1 second per move.
      Now, for this case, the engine is instructed that it has 10 minutes to think and the opponent has another 10 minutes. For this reason it now takes much longer than before (1 second).

      Could this be the problem?

      To emulate the old procedure, it is sufficient to limit the engine's thinking to 1 second.

      Delete
    2. I understand that, that's also why I wanted to find the latest version where they worked to help with backtracking any changes made.
      I found quite the old version on my computer, version 11.08a. Both engines work in that version. Unfortunately in R 1.27a, it doesn't matter whether I set a fixed depth, a fixed thinking time (I tried 1 second and 5 seconds) or a time control. ProDeo 1.6 won't make moves. The purple circle icon shows up and that's it. I also tried a 60 minute time control to see whether or not it's vastly slowed down, but still no move.

      Delete
    3. If possible can you send me the executable of one of the two engines or where I can download it to lukasmonk in gmail and I will try it directly.

      Delete
  12. Hello Lucas,

    I use the latest version on Windows 10. I noticed a problem in competition against the tutor. IF the tutor is enabled and IF you make several takebacks, the game freeze and don't answer at all. This don't happen if the tutor is disabled.

    Is there also a limit to the number of takebacks you can make ?

    I have also a question, do you keep the game played (like competition against the tutor) somewhere in a database ?

    Thanks for the program

    Yan

    ReplyDelete
    Replies
    1. I will try to solve problem with takeback and tutor.

      In Tools/Database there is one = __Autosave__

      Delete
  13. Hello Lucas,

    I have the latest version of your app installed on my pop os machine and every time I press the tools button nothing happens or the app crashes. Is this a problem with the app, and if not how can I troubleshoot?

    ReplyDelete
    Replies
    1. Perhaps, running with sudo may solve the problem.

      Delete
  14. Hi Lucas, I am new to Linux. I tried running your shell on a terminal and this comes out. Am I missing something?

    Verifying archive integrity... 100% MD5 checksums are OK. All good.
    Uncompressing Lucas Chess R 1.28a1 100%
    ./setup_linux.sh: 3: ./setup_linux.sh: [[: not found
    ./setup_linux.sh: 19: ./setup_linux.sh: ./setup_linux: Exec format error

    Thanks.

    ReplyDelete
    Replies
    1. My Chrome OS is 32, my Linux GNU is aarch64 (I'm using Ubuntu on Xfce!)

      Delete
    2. Sorry, I don´t know.
      If you want to install without .sh, here's a zip file:
      https://drive.google.com/file/d/1qKRR6s_rwWX4Ll53bax-m3U1fMdYKQde/view?usp=sharing

      Delete
  15. hello, in game stockfish and other engines, replicate their movement in a fraction of a second, how can you extend the response time while keeping a small depth of calculation ?

    ReplyDelete
    Replies
    1. I'm sorry, but I don't understand what you are asking, what program option are you on?

      Delete
    2. ho! sorry. Can we ask the GUI to play 4 or 5 seconds after my movement, while not increasing the depth of reflection. (a delay in the movement of the computer)

      Delete
    3. Right now there is no option available.
      This feature will be included in version 2.0

      Delete
    4. when I play against Fritz 17 it is a feature who add a very pleasant human dimension, thank you. No matter when it happens , take your time, each version of LChess is really nice. hoping that the year 2022 will be lighter, happy new year everyone.

      Delete
  16. Hello. First of all, thank you very much for this wonderful software. I really appreciate it. I like all the features. I am using on Linux and I realized that on Torneo-elo, there is a gap of players between elo 1350 and 1700. Looking into the source code i realized that players on this gap are not available on linux because they are based on "hamsters" and "amyan" engines, that, i think, are only available on windows. Are you planning to fill in this gap with players based on other engines available on linux? Maybe i could help....

    Another thing.... i bought the Millennium eOne and it works perfectly with lucas chess on linux via USB!!! Thanks to you again, and thanks to Graham for the drivers!!! Is planned to include the possibility of connecting the eOne via Bluetooth?

    ReplyDelete
    Replies
    1. This is a work done by Michele Tumbarello, and he used these engines to create very specific personalities and calculating an elo in that range, I guess it should not be easy to emulate a personality like the ones created for windows. Maybe with Rodent II and their personalities.
      In relation to eOne, Graham told me a few days ago, in relation to another similar question: "If he is connecting to the board using BluetoothLE then he needs to understand that the way the Low Energy bit works is by only sending data when something happens. So when he connects to the board it might not know where the pieces are until he actually lifts one up or moves one."
      A good idea might be to ask him directly (https://goneill.co.nz/index.phphttps://goneill.co.nz/index.php)

      Delete
  17. I use Linux Pop OS. Everything works well, but the Igel engine is broken :X

    ReplyDelete
    Replies
    1. Thank you very much. I have compiled version 3.0.10 and it works now in my PC. I will publish it in the new update.

      Delete
  18. Komodo 13 is now available for free download!
    https://komodochess.com/downloads.htm

    ReplyDelete
    Replies
    1. Thanks, it will be included in the next update.

      Delete
  19. I can't install the GUI on Ubuntu 22.04 iirc, it said: ./setup_linux.sh: 3: [[: not found

    (setup_linux:51146): GLib-GIO-ERROR **: 17:08:43.120: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'
    Trace/breakpoint trap (core dumped)

    ReplyDelete
    Replies
    1. I have no idea what the problem might be,
      Doing a google search, for example at https://forum.garudalinux.org/t/no-such-key-antialiasing-error/11825 suggests:

      Remove the lines containing antialising in usr/share/glib-2.0/schemas/25_gnome-default-settings.gschema.override and then, recompile schema, sudo glib-compile-schemas /usr/share/glib-2.0/schemas Beware! This might break your schema! Make backup before performing this.

      Delete
  20. Hello! I've downloaded last version for linux (R2.02, because there is no R2.02a for linux, i think), and the new Rodent II personalities feature does not work (when clicking on Rodent II personalities, no personalities appear)
    Regarding the Chess Leagues..... that is great!!! Thank you!! Could it be possible to add the option of humanizing the time used by the engine against a human in the Chess Leagues, as you implemented in the normal game? Thank you very much for this wonderful software!!!!

    ReplyDelete

Post a Comment

Popular posts from this blog

R 1.06 Maia

 This update contains a major improvement with the inclusion of Maia. Maia is a neural network chess engine, created with the purpose of making her movements as human as possible. The Maia creation team has prepared 9 versions, from 1100 to 1900 of elo, and thus they have been included in Lucas Chess. You have all the information about Maia at: https://maiachess.com/

Version R

New version of the program. Continuist at user level with the previous one, but with great internal changes. This new version has been mainly tried: Update the code to a current version of the compiler, from python 2.7 to python 3.7 (based in a previous work of Alfonso Solbes). Update the graphic library, from version 4 to 5 of qt, via pyside2. Improve folder organization, with Linux support in mind. Negative consequences: It is incompatible with Windows XP. The data is not compatible with previous versions of Lucas Chess. The weight of the installer has doubled, currently around 120 Mb and the disk installation occupies 338 Mb.